Back to overview
Resolved
The inbox is not loading correctly
Jul 28, 2026 at 8:25pm UTC
Affected services
app.kapso.ai
Resolved
Jul 28, 2026 at 8:29pm UTC
The inbox is now working correctly.
Affected services
Created
Jul 28, 2026 at 8:25pm UTC
The inbox is not loading correctly. The issue is identify and we are pushing a fix.
Affected services